Naming convention for boolean returning methods
There's a convention for boolean property accessors to name them like isX(). Does it apply to all boolean returning methods that are not invoked for their useful side effects, like this one? Also, should I replace "is" with "are" if the noun is plural? "Follow you team's guidelines" is not applicable since we have none (but I wish to bring more sense into the codebase). // inside JTable wrapper public boolean multipleRowsSelected() { int[] selectedRows = getSelectedRows(); return selectedRows != null && selectedRows.length > 1; } Java.

There's a convention for boolean property accessors to name them like isX()
.
Does it apply to all boolean returning methods that are not invoked for their useful side effects, like this one?
Also, should I replace "is" with "are" if the noun is plural?
"Follow you team's guidelines" is not applicable since we have none (but I wish to bring more sense into the codebase).
// inside JTable wrapper
public boolean multipleRowsSelected() {
int[] selectedRows = getSelectedRows();
return selectedRows != null && selectedRows.length > 1;
}
Java.